View Full Version : Gecko 203v intermittent fault

Thu 24 July 2014, 07:54
Gecko 203v intermittent fault

The problem i am having is with my z azis when i switch my cnc in the morning, and try to move the z azis
using the page up page down buttons no movement.
if i then shut down and restart i then get movement.
i have checked continuity on all connectors and they are ok.
just wonder if this problem might be with the gecko drive.
how can i prove this before replacing the drive
thanks paul

Thu 24 July 2014, 09:34
In my opinion it's not a Gecko problem but something related to your parallel port.

Thu 24 July 2014, 09:47
ok thanks Parrulho.
any idea how i can go about trouble shooting this problem?

Thu 24 July 2014, 09:54
If you want to test your gecko you can swap the Z gecko with another axis.

for parallel port, start with the driver, try to see if there is an updated driver. do you have a PCI parallel port or is it integrated on PC motherboard?

Thu 24 July 2014, 20:51
The Jog lockout in Mach3 may have been active. Are you sure that it was not active?

Thu 24 July 2014, 23:00
i had intermittent z axis twice - both times were bad motors.

Fri 25 July 2014, 09:53
It look like the problem was the parallel cable just changed the cable
but i am still not sure if the problem is corrected
will have to see how it goes in the next few days
that is what happens with intermittent faults
Can you still get computers with parallel ports
i use a very old dell computer not sure how much longer it will last.

Fri 25 July 2014, 10:40
Here are four basic approaches to solving the parallel port problem these days:

1) Buy some old computers. There are large quantities of refurbished corporate desktops (http://www.overstock.com/Electronics/Desktops/132/subcat.html?TID=TN:ELEC:Desk) on the market. This is probably the cheapest and simplest option, but may have the shortest working life.

2) Buy a new computer that has a PCI slot and add a parallel port. This is probably the most expensive option these days, as PCI slots are no longer mainstream and appear in the pricier / enthusiast models.

3) Get something that replaces the need for a parallel port, like a smoothstepper. Make sure that what you get is compatible with the software you use. Good choice for Mach3 users.

4) If you're more on the experimental side, look at some of the work being done with small computers for the electronics hobbiest. The most directly applicable example I've seen is with the BeagleBoneBlack (http://xylotex.netfirms.com/OSCommerce/catalog/product_info.php?cPath=27&products_id=52). I have driven a G540 based mill with this as an experiment, have not tried in on the MechMate yet. Probably reasonable only for those with prior LinuxCNC experience.

Fri 25 July 2014, 14:09
I recommend to use a PCI parallel card instead of the integrated one. (startech is still producing cards). The integrated parallel port, most of the times do not send signals at 5V but at 3.5V. If your "printer cable" is not one of good quality it's easy the signal get lost...

otherwise, the option 3) from Brad is a good solution.

Sat 26 July 2014, 12:27
I'm with Paulo on the importance of using a PCI parallel card. It's not just that the voltage is higher at 5V vs 3.5V, it's also that everything is better - the transistors driving the signal are larger, the traces on the PCB are larger and shorter, the interconnect wires in the chip are larger, etc. That's because the parallel port is one of the oldest, slowest, highest current components that has been integrated into the southbridge (http://en.wikipedia.org/wiki/Southbridge_(computing)), and it is pretty weak and fragile compared to the less integrated chips on the PCI cards. None of 'em can compare to the original Intel 8255 chip, a 40 pin DIP beast that was almost impossible to kill - but then our computers are now 4,000 times faster than those ones.

Sat 26 July 2014, 12:39
The only problem with some PCI cards is the bi-directional use of pins 2-9. I ran into this with installing my 108 input card. I originally ran the machine from the integrated Parallel port as port 1 and port 2 was the PCI card. I could not receive any feedback from the pci card on pins 2-9 on port 2. I tried numerous actions, drivers, etc and finally found that by switching port 1 to the PCI card and port 2 to the integrated parallel port the problem was eliminated. So it is also the manufacturer of the pci card and the protocols they follow that make it more usable just realize that the 108 input will not function properly on some of them. As far as running the Mechmate from a PCI card....It runs flawlessly.

Sun 07 September 2014, 20:19
its no more an intermittent problem z now does not move.
its not the motor as i have swapped supply and motor works
i took a voltage reading on the z g203 between step and common and got 1.36v
on .all the other z g203 i get 0 reading.
not sure what this means
thank again Paul
i am using breakout board PMDX 122

Mon 08 September 2014, 08:59
Paul, the signal on the step line should toggle back and forth between (close to) zero and above 3v ("close to" 5v). When the motor is stopped, it should be at one or the other. When the motor is in motion, a meter will read it as a voltage somewhere in between.

So, if you hook up the meter and jog an axis a few times, you should see the voltage stop near zero and 5v; while it is moving, voltage somewhere between.

You are describing an in between voltage at the G203, which is after the PMDX 122's buffers. The scenarios I can think of are:

1) Some kind of wiring error or partial short. Is humidity based corrosion a concern there?

2) Blown input circuitry on the G203.

3) Blown driver circuitry on the PMDX 122.

4) Insufficient power supply to the PMDX 122.

As it was apparently working, then degrading, and now failed, I'm inclined to look for marginal conditions like corrosion or not enough power to the PMDX 122.

Have you tried contacting PMDX for some tech support? They are well regarded for helping folks.

Mon 08 September 2014, 11:28
Thanks Bradm
i have checked the breakout board
by swapping the inputs and it proved its not the board (i think)
also check the motor and its not the motor
there is some corrosion problem as i live close to the sea
i went and place an order for a new drive.
if that fix the problem. will send the old one back to have it checked out
if its the drive then this will be the second one i will have to replace.
do you know if there is a step by step way i can go about trouble shooting
these drives?
trouble shooting guide for dummies. type of thing.
thanks again for taking time to help
thanks paul

Mon 08 September 2014, 13:47
From GeckoDrive (http://www.geckodrive.com/g203v-troubleshooting)

Fri 12 September 2014, 13:02
Hi Bradm
the problem turned out to be the breakout board i call PMDX tech support and they talk we through it
j3 was not working
i had j4 spare so i put the z on it
well i now have a spare Gecko drive

Fri 12 September 2014, 13:11
Glad you're up and running, and that PMDX came through for you.

Spare Gecko? You're on the slippery slope to adding another axis :)

Fri 12 September 2014, 17:54
I have had a failure on J3 too in the past and had to move to J4 for the Z axis.
.....note that one in the files.