PDA

View Full Version : Newbie needs help with figuring out drive configurations (slaved drive for x-axis)


ikeike
Thu 31 December 2009, 15:06
Hi All,
Iím new to the forum and am excited about the prospect of my future MM build. As of now Iím trying to get acquainted with all the cnc terminology and develop a general sense of how this thing will go together and work. The one issue I am having currently is figuring out how the two steppers for the X drive work harmoniously to move the gantry. I understand that each of the two steppers must turn exactly opposite of each other to achieve a synced movement and drive the gantry. I see from pictures on the forum that there are four separate drives, one for each motor. Is the syncing done within the cnc software (Mach3), or is this achieved with some type of wiring configuration within the control box or motors. If you could help describe what is going on here or point me to somewhere within the forum or elsewhere that explains this I would be very grateful. Thanks so much. I look forward to more cnc banter. I canít get enough!

MetalHead
Thu 31 December 2009, 15:39
In the software - Their are settings to slave the drive. Each motor is wired independently.

That is the standard method for the MM. You can share a Gecko on the X drive and not have a slave. Some are using this approach with no issues, but it is not in the plans as a standard config.

Search and reading is your friend on this site. Read a lot :D

aniljangra
Fri 01 January 2010, 06:16
You can share a Gecko on the X drive and not have a slave. Some are using this approach with no issues, but it is not in the plans as a standard config.

I guess, that means not sharing one Gecko for both motors but sharing step/dir signals from BoB to two Gecko's driving two X-motors. Sorry if Its me that misinterpreted :)

MetalHead
Fri 01 January 2010, 06:56
Yes - Thanks for clearing that up.

http://www.mechmate.com/forums/showthread.php?p=7472&postcount=8

Re-read it myself this morning.

and this one also.

http://www.mechmate.com/forums/showthread.php?p=7491&postcount=10

domino11
Sat 02 January 2010, 21:58
Also if I can add one more thing, this sharing step and direction signal with two gecko 203Vs. This will not work with the pmdx and the G201 or G202 as I recall. It will work with 2 G203vs. They do not need as much drive current from the pmdx. :)

smreish
Mon 04 January 2010, 22:06
Heath.
Correct - you must use the G203 drives if you want to share the step/dir on a "y" cable. The sink/source current is ok for the 203 drives but NOT the others. Mike wrote a VERY lengthy post explaining why......and now I can't find it to refer too....