MechMate CNC Router Forum

Go Back   MechMate CNC Router Forum > Personal Build Histories > MechMates already cutting
Register Options Profile Last 1 | 3 | 7 Days Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old Tue 07 August 2007, 01:35
Alan_c
Just call me: Alan (#11)
 
Grabouw (Western Cape)
South Africa
Send a message via Skype™ to Alan_c
Chinese Spindle Has Arrived! #11 – Grabouw (S. Africa)

Greetings all

After being an active observer for some time and asking the odd question and making the odd observation, its time I started documenting my build. Firstly I want to thank the forum for all the input so far as all those bits of info and gems of knowledge helps make it easier. I am also fortunate enough to be within calling distance of Gerald (phone and visit) so no challenge or difficulty will be insurmountable.

I am building the machine for my Father to use in his business (makes wooden educational equipment) so he is supplying the budget, He gets a productive machine and I get to build it (arenít Dads great?)

Currently I am busy with the control panel (kitchen table project, though in my case itís more like the garage workbench project) and have acquired most of the electrical components except the Geckos (waiting for funds, should be this week) and spindle motor with VFD. The Spindle will come much later as that has to be imported and we donít need it now anyway. I donít know if the other guys who have gone this far will agree with me but most (80%) of the cost of the MechMate is in the electrics (incl spindle and VFD) so if you are going to build it, build it as big as possible that your space and work type allows, the steel for the table and gantry is a minor cost (relatively).

My Specs so far:

3 Phase 380V main supply.
Bob Campbell BOB and relay board.
300VA Power Supply.
4x Oriental Motor PK299-F4.5A 2.8V Stepper Motors
4x Gecko 203V stepper drives
Table size to take 2.75m x 1.83m (9í x 6í) boards
3KW HSD Spindle
Delta VFD Inverter

The pics below show some of the electrical components, base plate for the panel with most of the components placed and my test rig to test the workings of the electrical panel.


I have gone with a slightly different layout on the panel due in part to the size of the Campbell BOB and relay board, and that I will be mounting the geckos on a heat sink mounted over a cut-out on the left side of the box, as seen on a project on CNCZone. This configuration will hopefully not need a fan inside, but if the internal temperature does get too high I can always add one. I am building the panel into a second hand (read free) box so there are some extra holes that will not be required, these will be closed up.

While doing some more reading last night, I fear I may have an underpowered power supply. I managed to get the steppers locally as part of a very sweet deal, but had already decided on a 300VA transformer as I assumed that it would be correct (yes yes I know never assumeÖ) and got caught up in the excitement of buying components without checking every detail. The 300VA supply would work great for 1Amp motors, but these beautiful shiny new babies are rated at 4.5Amp Unipolar, which by my calculations will require at least 600VA (50x4.5x4x0.67 = 603). What should I do? I am sure (here he goes assuming again..) that the current power supply will work for the testing and building phase, but will I need to upgrade when it comes to doing the serious work?
Attached Images
File Type: jpg components1.jpg (93.4 KB, 5091 views)
File Type: jpg electrical1.jpg (105.1 KB, 5108 views)
File Type: jpg testPF1.jpg (91.3 KB, 5019 views)
File Type: jpg testPR1.jpg (103.2 KB, 5022 views)
Reply With Quote
  #2  
Old Tue 07 August 2007, 01:38
Alan_c
Just call me: Alan (#11)
 
Grabouw (Western Cape)
South Africa
Send a message via Skype™ to Alan_c
An updated photo of the panel and test board with some of the wiring done.

I have used mostly 1.5mm wire as I had it on hand, but will be changing some of them to 0.75mm where possible. The lower bank houses from left to right the main disconnect with 4th pole, MCB to protect the control circuit, motor and PSU contactor, terminal blocks for internal power distribution, space for Siemens Thermistor Relay, Connector blocks for fan motor and thermistor, Connector blocks for 220V E-stop circuit and VFD control signals. In the space above is the relay board and connector block for the inputs to the BOB. The connections to the Geckoís will be off the BOB on the right hand side. My aim is that all 220v wires will cross signal wires at 90 deg or be sufficiently separated from them. Most of the mains current will be on the left and the signal lines on the right.
Attached Images
File Type: jpg panel wired1.jpg (90.1 KB, 4962 views)
File Type: jpg testPR2.jpg (108.0 KB, 4932 views)
Reply With Quote
  #3  
Old Tue 07 August 2007, 03:51
Gerald D
Just call me: Gerald (retired)
 
Cape Town
South Africa
You make it look too pretty!

Yes, the cost is mostly in the electrics. And for me that is also where the learning curve and sleepless nights lie. A "simulator" like this is worth its weight in gold. It is NOT wasted time before building the real thing - this is the real thing!

That big capacitor without any load on it can give a nasty surprise - it will probably take 10 minutes to discharge low enough to make connections to it.

You will find out if your 300VA transformer is too small if it gets hot. If it doesn't get hot, then it is okay. Don't loose any sleep over that now. (It doesn't cause loss of performance if it is too small). What you can do now is to see if your capacitor is big enough - quite simple to add a second cap in parallel.

No need to replace neat 1.5mm2 wiring with 0.75mm2. You will not gain anything by this.

Where will your cables enter your cabinet? Have you got enough space for the first stiff bit of cable after the gland before you can bend it in the right direction? One needs to be careful of working too close to the edges of the back plate inside the housing.

Don't underestimate the mass of wires going to the Gecko's for the simulator project. There are 9 wires per Gecko, 36 wires in total - some with nasty consequences if they come loose or short out. Moving the motor panel, the back panel and heat sink around on the kitchen table can be an enlightening (briefly) experience.
Reply With Quote
  #4  
Old Tue 07 August 2007, 10:21
Richards
Just call me: Mike
 
South Jordan, UT
United States of America
You've done a beautiful job in layout and design! As far as the 300W power supply goes, if it gets too hot (as Gerald explained), replace the current limit resistors in the G203 stepper drivers with resistors specified for 1.5A or 2A. That will reduce the usability of the 299-F4.5 motors (which are excellent motors) until you can upgrade the toroidal transformer to a larger unit. You may find that the 300W unit is perfectly adequate. It all depends on how many axes are active at the same time and how hard you are pushing the motors. On my test bench, my 500W transformer never gets hotter than room temperature, which means that a 300W transformer would be more than adequate. (However, a 'standard' transformer at my second test bench always runs hot, even though it is 2X the required size. It's just the difference between a toroid transformer and a standard transformer.)
Reply With Quote
  #5  
Old Tue 07 August 2007, 10:59
Marc Shlaes
Just call me: Marc
 
Cleveland, OH
United States of America
Send a message via Skype™ to Marc Shlaes
Beautiful!

What J.R. did to raise the bar on the mechanical side, Alan_c has done for the simulator. I intend to follow this lead precisely.

But... Gerald, we still owe it all to you. You are bringing out this level of excellence.

This is awesome!
Reply With Quote
  #6  
Old Tue 07 August 2007, 11:00
Alan_c
Just call me: Alan (#11)
 
Grabouw (Western Cape)
South Africa
Send a message via Skype™ to Alan_c
Thanks Mike & Gerald

The cable will enter the top of the box on the left hand side (adjacent to the transformer) and enter the trunking just below the transformer, where it will then go to the top of the main disconnect.

The pics dont show it very clearly, but the panel is resting on a desk-top easel which has space for the Geckos and heatsink on the right. This allows me to change the angle of the panel so I dont have to reach over too far to get to items at the top. If the panel and Gecko heatsink are on the same support I should avoid any fireworks while moving things around
Reply With Quote
  #7  
Old Tue 07 August 2007, 11:19
Gerald D
Just call me: Gerald (retired)
 
Cape Town
South Africa
Marc, it is good to see this great work, but it makes it difficult for a lot of others to freely show what they have done. This is just a note to encourage everyone to share their progress, particularly those that have never tackled anything like this before and who are climbing a big mountain.
Reply With Quote
  #8  
Old Tue 07 August 2007, 13:27
Marc Shlaes
Just call me: Marc
 
Cleveland, OH
United States of America
Send a message via Skype™ to Marc Shlaes
Good point! I'll remember that.
Reply With Quote
  #9  
Old Tue 07 August 2007, 14:23
Greg J
Just call me: Greg #13
 
Hagerman, New Mexico
United States of America
Alan,

Very nice work!!

Look forward to your progress.

Greg
Reply With Quote
  #10  
Old Wed 08 August 2007, 10:28
Alan_c
Just call me: Alan (#11)
 
Grabouw (Western Cape)
South Africa
Send a message via Skype™ to Alan_c
Here is a PDF of my electrical panel circuit, just remember this is only applicable to my machine and I accept no responsibility for any faults in this document. This is neither a reccomended nor approved circuit diagram and I am sure MechMate accepts no responsibility.

With the legal disclaimer out of the way, please review and comment where anyone can see any major glaring faults. If you can use any ideas please do so, but if its wrong dont blame me - I am no electrical engineer.
Attached Files
File Type: pdf Panel Wiring 380V.pdf (240.3 KB, 607 views)
Reply With Quote
  #11  
Old Thu 09 August 2007, 17:00
Alan_c
Just call me: Alan (#11)
 
Grabouw (Western Cape)
South Africa
Send a message via Skype™ to Alan_c
Advise needed with my control circuit.

I am using the Bob Campbell Board with relay board. This relay board has 4 relays. The fourth relay (RL4) is activated by the charge pump so the NO contacts are closed. This enables one to use this relay to control the power to the PSU and Inverter.

I have wired my supply for the control circuit through this relay so when the charge pump signal is not present, the NC terminals will light a panel front light labeled FAULT. This also inhibits any current from the start button. When the charge pump signal is present, the NO contact will close, extinguishing the light and allowing current to flow to the start button. If the start button is pushed current flows to the coil to energise the contactor. As the contactor has a latching circuit the contactor will remain closed until one of the stop or E-stop buttons are depressed. When this contactor closes, current flows to the PSU and Inverter. So far so good…

The low voltage E-stop circuit also flows through a relay inside the inverter that is normally closed when all is good. Should the inverter “fault” for whatever reason, this relay contact will open causing the BOB to generate an E-stop signal to MACH which will stop sending the charge pump signal, this will cause RL4 to open.

Now I have two ways of wiring this circuit, see the attached drawings.

In the first circuit, when RL4 opens, the contactor will not release as it is not in line with the latching circuit. This means there is still power to the inverter and PSU although of course all motion and the spindle would have stopped because of the missing charge pump signal. The fan on the inverter would still be operational, as it would be receiving power.

In the second circuit, when RL4 opens, the contactor will release as it is in line with the latching circuit. This will cause all power to stop flowing to both the PSU and Inverter as would usually happen when one of the E-stop buttons is activated.

I am not too keen on the idea of cutting all power when the inverter faults (too much like pulling the plug from the wall). I can understand when there is blood or smoke that pushing an E-stop does this, but is it advisable for this drastic action with a relatively minor thing like an inverter fault?

Mind you when an overheating spindle triggers the thermal relay, it has the same effect as pushing an E-stop button (AC1Q2 Term 95 & 96), which is in line with the latching circuit causing the contactor to drop out, so am I being over sensitive to the needs of my inverter (sounds like Dr Phil) or is it just too late at night?

Any comments gladly accepted.
Reply With Quote
  #12  
Old Thu 09 August 2007, 17:02
Alan_c
Just call me: Alan (#11)
 
Grabouw (Western Cape)
South Africa
Send a message via Skype™ to Alan_c
Here are the files as mentioned above
Attached Images
File Type: jpg circuit1r.jpg (66.2 KB, 4777 views)
File Type: jpg circuit2r.jpg (63.8 KB, 4762 views)

Last edited by Alan_c; Thu 09 August 2007 at 17:06..
Reply With Quote
  #13  
Old Fri 10 August 2007, 05:44
Gerald D
Just call me: Gerald (retired)
 
Cape Town
South Africa
Hi Alan, I am getting some A3 paper to make a readable plot before I can comment - not avoiding you, promise.
Reply With Quote
  #14  
Old Fri 10 August 2007, 05:48
Alan_c
Just call me: Alan (#11)
 
Grabouw (Western Cape)
South Africa
Send a message via Skype™ to Alan_c
If you need PDF files e-mailed to you directly, let me know as I dont know how well those images will print.
Reply With Quote
  #15  
Old Fri 10 August 2007, 08:17
Richards
Just call me: Mike
 
South Jordan, UT
United States of America
Alan,
I have no answer to your question because, it seems to me, that either option would work, depending on your personal preferences.

The design that I'm playing with allows only the E-stop switch to open the main contactor - which kills all power to the box just as if the the door switch were opened or the main breaker on the subpanel were opened. All other major circuits will have their own latching contactors. In other words, the VFD will receive its power from the main contactor, which is controlled by the E-stop switch, but it will also have a contactor that controls the low voltage circuit to the start/stop/run inputs. That circuit will require the main controller to output a steady-state signal to the contactor AND a manual momentary switch closure to latch the contactor ON before the spindle will start. The latch circuit for the spindle can then have its own stop switch as well as a temperature operated switch.

The steppers may also have a similar circuit. Power to the steppers might be controlled by the main contactor, but the common signal line for the step and direction signals might be controlled by a latching contactor. That would allow the main controller to activate the contactor with a steady-state signal WHEN the operator pressed a manual momentary switch to latch the contactor ON. That circuit could also incorporate limit switches (with manual bypass switches) as well as an emergency kill switch.

The idea behind multiple contactors is to be able to isolate any circuit so that the operator could perform some function without being injured. For instance, the contactor controlling the spindle could be locked out while the operator changed a cutter. (In my example, the spindle contactor circuit is not fail-safe, since only the run/start/stop circuit is disabled. Power would still be present at the spindle.) The contactor controlling the steppers could be locked out to enable the operator to position material on the table.

The complexity of a controller can easily become almost unmanagable if safety circuits are installed to preclude every possible problem. In a real-world situation, if I were the only person operating the machine, I would have minimal safety devices installed, with the hope that I would be prudent and cautious while operating the machine. However, if I hired someone else to run the machine, I would need more safety related circuitry to protect the operator - and to protect me from being sued in case of an accident. If more than one person were to operate the machine - at the same time - for instance, one person changing the cutter while another person positions material on the table, then I would have to maximize the safety circuits so that everyone is protected from the machine and from each other.

(If possible, consider visiting a computerized machine shop or woodworking shop that uses 'big iron' equipment. Note the various safety devices built into the machinery. The suppliers of 'big iron' equipment have to comply with all required safety regulations.)
Reply With Quote
  #16  
Old Fri 10 August 2007, 09:06
Gerald D
Just call me: Gerald (retired)
 
Cape Town
South Africa
Alan & Mike

Havn't looked at the questions in detail yet, but there is a general problem in trying to E-stop a VFD powered motor, not just for CNC.....

The quickest stop is to remove the command to the VFD, but leave the mains power connected - this applies "reverse current". But, will this always work if the VFD is faulty?

The surest way to stop the motor is to remove the mains power, but then the spindle/motor takes forever to come to standstill (will be quicker if it was gnawing at your hand)
Reply With Quote
  #17  
Old Fri 10 August 2007, 12:09
Gerald D
Just call me: Gerald (retired)
 
Cape Town
South Africa
Alan, have looked at this now and your first big pdf looks okay. You have a solid grasp of what does what and why so I am going to leave you to make your own choices

But a couple of comments could help to sway you......

If the VFD inverter faults, or if the spindle overheats, you can use this to sound an alarm before it stops the spindle, giving you time to stop the job elegantly without losing calibration positions. Snag is, this will be so rare that you won't recognise the alarm.....

Or you can relay inverter fault and overtemp to "feedhold" with a timer shutdown (spindle stop) a second later.....

Loss of charge pump signal is rather drastic. By then all calibration would have been lost. A "drastic" E-stop won't make the situation any worse.

A VFD inverter can cope with mains failure quite happily - no problem to switch mains (even under load) once or twice a day. The VFD guys just don't want you to use that as the primary method for stopping and starting a motor, but they accept that mains is cut under E-stop conditions.

If something makes the spindle stop, you want the steppers to stop pronto before mechanical damage results.

If the steppers stop mysteriously, the spindle should stop soonish before a fire breaks out.

Things can go wrong in mysterious ways and systems can be built to detect the causes, but the foolproof way is to shoot first and ask questions later.

Don't forget to (E) stop the dust collector and vacuum table if a fire situation is developing.

Consider a mechanical switch to lockout the spindle while you change cutters (We had one near miss....)
Reply With Quote
  #18  
Old Thu 16 August 2007, 06:16
Alan_c
Just call me: Alan (#11)
 
Grabouw (Western Cape)
South Africa
Send a message via Skype™ to Alan_c
Thanks for the replies above.

Elsewhere in the forum the matter of grounding is discussed and the requirement to keep computer grounds seperate from the control panel ground, so am I correct in assuming that if I am to mount a Serial cable connector to the control panel enclosure (projecting through the side of the enclosure so that I connect the serial cable from the computer to the connector with the wire inside going to the BOB) that this connector must be isolated from the steel enclosure. I want to do this so that I dont have a big hole for the serial cable end to pass through that then needs to be closed/sealed against the dust.
Reply With Quote
  #19  
Old Thu 16 August 2007, 06:39
J.R. Hatcher
Just call me: J.R. #4
 
Wilmington, North Carolina
United States of America
Send a message via Skype™ to J.R. Hatcher
Alan could you cut the end off the cable, fit a rubber gromet in the control box and get a new cable end and hood then solder it on from the inside? The only down side I see to this is if the cable goes bad later down the road you will do it again.
Reply With Quote
  #20  
Old Thu 16 August 2007, 10:35
Gerald D
Just call me: Gerald (retired)
 
Cape Town
South Africa
Alan, we have a big slot (yellow) in the bottom of the box where the connector enters. The plan was fit a (blue) cover plate with a (red) split grommet, but there is so little dust in the box that we havn't bothered to do it yet. (PS. it is a parallel cable, not serial)

Reply With Quote
  #21  
Old Fri 17 August 2007, 01:24
Alan_c
Just call me: Alan (#11)
 
Grabouw (Western Cape)
South Africa
Send a message via Skype™ to Alan_c
With the Campbell board, you don't bring the printer cable all the way to the BOB - the ribbon apparently goes to the side of the box and that's where the printer cable meets it.

My question is must this cable port be isolated from the case?

If I measure mith my multimeter on the metal casing at either end of the PARALLEL cabel I get continuity, so if the port (which is metal) is connected to the cable, and the other end of the cable is connected to the computer which is also metal and is earthed, will I be inducing a ground loop?
The earth prong of the computer supply cable is connected back to the case of the control panel as it gets its power from there. The earth of the case is common with the earth of the computer.
Next question, is the "ground" that we have to keep seperate, isolated from earth at the computer side as well?
Reply With Quote
  #22  
Old Fri 17 August 2007, 03:07
Gerald D
Just call me: Gerald (retired)
 
Cape Town
South Africa
Everybody agrees a cable shield should not be connected at both ends, but there is no discussion that I can remember about the shield of a printer cable being connected at both ends. Maybe all printer cables are not like that?

On our PMDX it is not an issue because the whole BOB "floats" away from earth. We did earth it by mistake in the beginning and had some interference problems. PMDX does have "isolated" BOB's that can be grounded apparently, but I am not sure what exactly this means. Maybe your Campbell board is isolated, but that doesn't get rid of the ground loop, maybe the ground loop doesn't matter if the BOB is of the isolated type. It is all Greek to me!

Why not cut a big hole, mount a plastic sheet over it, and then mount the port in the isolated part? That could cut out a lot of "maybe" discussions.
Reply With Quote
  #23  
Old Fri 17 August 2007, 08:51
Richards
Just call me: Mike
 
South Jordan, UT
United States of America
If possible unscrew the covers from each end of the parallel cable to see if the shield is just soldered to the metal part of the connector. If that is the situation, cut the shield conductor and tape off the shield at one end of the cable (preferably the end that connects to the computer - but either end will work).
Reply With Quote
  #24  
Old Mon 20 August 2007, 05:59
Alan_c
Just call me: Alan (#11)
 
Grabouw (Western Cape)
South Africa
Send a message via Skype™ to Alan_c
My parallel cable that I will be using has moulded ends so that is not an option. On an old severed cable I have, the shield is a mylar film with an uninsulated wire connecting the two metal cases at either end. To over come any doubts, I have made an insulating mounting for the port. pics to follow soon...
Reply With Quote
  #25  
Old Mon 20 August 2007, 14:52
Alan_c
Just call me: Alan (#11)
 
Grabouw (Western Cape)
South Africa
Send a message via Skype™ to Alan_c
Here are some more update pics.

No1 shows the insulator I made for the parallel port

No2 shows the arrangement fitted to the case

No3 is an internal view

No4 Shows the Geckos mounted on the heatsink (darn those critters are small!) You may also notice all the labels on the interconnecting wires of the panel - that helps me make order of what could be a tangle of spagetti. All my circuit diagrams have corresponding labels and numbering and I have made a spreadsheet listing every wire with its identifier, source and destination, (still to add length), colour and size. my thinking is that if I make fault finding so easy, I hopefully wont have to...
Attached Images
File Type: jpg insulator1.jpg (67.5 KB, 4672 views)
File Type: jpg insulator mounted.jpg (43.9 KB, 4616 views)
File Type: jpg insulator inside.jpg (72.0 KB, 4623 views)
File Type: jpg panel with geckos.jpg (104.5 KB, 4635 views)

Last edited by Alan_c; Mon 20 August 2007 at 14:57.. Reason: spelling
Reply With Quote
  #26  
Old Tue 21 August 2007, 00:57
Gerald D
Just call me: Gerald (retired)
 
Cape Town
South Africa
Yup, those Gecko's are small and light, and the first reaction is "Is this what all the fuss & expense is about?"

On printer cables....
There have been rare reports of printer cables that don't have the full 25 cores. They only have the minimum necessary to make a printer work.
Reply With Quote
  #27  
Old Thu 23 August 2007, 14:09
Belli
Just call me: Greg
 
Johannesburg
South Africa
Printer cables

Hi All,

Printer cables have all 25 connections, what you are referring to is 'Modem' cables which have nine connections and will be marked as such, worse offenders are 'Null modem' cables which have nine and two connections reversed. If if it has the centronics connectors it's a printer cable for sure but they are very difficult to find now and rarely used.

Cheers
Reply With Quote
  #28  
Old Thu 23 August 2007, 15:25
Gerald D
Just call me: Gerald (retired)
 
Cape Town
South Africa
An 18 core cable is sufficient to make a printer (and a BOB for CNC) work (pin no.'s 18 to 25 can be served by a single core - all ground).

I shouldn't have said "printer" cable - as Belli points out, there are a variety of cables with DB25 connectors on the ends and funny things happening on the cores.
Reply With Quote
  #29  
Old Fri 24 August 2007, 07:58
Richards
Just call me: Mike
 
South Jordan, UT
United States of America
Modem cables usually have 9-pin or 25-pin connectors on both ends while a printer cable that is used with a PC has a 25-pin male connector at the computer end and a male Centronics connector at the printer/BOB end.

Belli is correct about serial cables. Before IBM joined the Personal Computer arena, it seemed that each device manufacturer tried to invent their own wiring schemes. Instead of standardizing on DTE or DCE (depending on whether the device was considered to be a terminal or a computer) and using the protocol that defined how each conductor/signal was to be used, everyone danced to their own tune. Back then, I owned several break-out-boxes so that I could switch conductors around until I found a combination that worked for a particular device. Even after figuring out the wiring scheme, we often had to write custom serial drivers to use the "handshake" signals in non-standard ways.

But, back to printer cables. I've found that printer cables that are designed to work with Laser Printers have worked properly with my PMDX-122 BOB.
Reply With Quote
  #30  
Old Sat 25 August 2007, 09:56
Alan_c
Just call me: Alan (#11)
 
Grabouw (Western Cape)
South Africa
Send a message via Skype™ to Alan_c
Its Alive...

Whoohoo it lives...

Just completed wiring the test panel, gingerly switched on, checked BOB as per instructions - all OK, switched on power supply - no exploding caps (what a releif), but the system keeps faulting indicating a limit is activated - not using shielded cable on test bench so the 220V signal lines are causing inteference, moved them away from the input signal lines, now it starts with no fault...pushed left arrow on keyboard...HOORAAAAH Ive got that stepper motor motion rush, I'm sure you wont get the smile off my face for a week.

All motors turn on command, no smoke from any possible sources, no heat at all (should I be worried), ran some G-code files and all seems cool, the system e-stopped occaisonally but I am sure it is only because of the unshielded cables.

Busy enjoying an ice cold Windhoek (best local beer) and thoughts of thanks to all on the forum and especially to Gerald, this would not have been possible without you - THANK YOU
Reply With Quote
Reply

Register Options Profile Last 1 | 3 | 7 Days Search Today's Posts Mark Forums Read

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cool Panel Cover Logo #107 - Dakovo, Croatia marko cro MechMates already cutting 271 Sun 01 March 2015 03:31
Touch Probes Have Arrived #72 - Brisbane, Australia skippy MechMates already cutting 130 Mon 04 March 2013 05:31
Update on new Chinese Water cooled Spindle waynec 50. Toolheads 84 Sun 01 January 2012 21:31
Chinese 300Hz spindle BartDeckers 50. Toolheads 6 Thu 29 December 2011 13:41
Chinese 2.2kw Spindle and Mach3 Radishworks 50. Toolheads 14 Tue 11 January 2011 09:53


All times are GMT -6. The time now is 04:01.


Powered by vBulletin® Version 3.8.3
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.