MechMate CNC Router Forum

Go Back   MechMate CNC Router Forum > Electrical & Electronic > 701. Motor Drives
Register Options Profile Last 1 | 3 | 7 Days Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old Sun 15 March 2009, 04:54
Francois
Just call me: Francois
 
Springs
South Africa
QJ8060 Drive from CW-Motors

Hi my name is Francois and I am a newbie to MM.
Iíve been to Kobus place to sea an actual MM and it is most impressive.

My questions is what makes a good driver, are we looking for a driver witch can handle high amps. Will this driver work what am I suppose to be looking for in a driver
Attached Files
File Type: pdf QJ8060.pdf (570.6 KB, 208 views)
Reply With Quote
  #2  
Old Sun 15 March 2009, 10:30
Richards
Just call me: Mike
 
South Jordan, UT
United States of America
Depending on the motor that you choose to use, the QJ8060 stepper driver looks pretty good. After Gerald told me about the Gecko stepper drivers a few years ago, I have only used Gecko products. They do everything that I expect them to do at a reasonable cost.

The unit that you're interested in has selectable microstepping. The 1/10 setting would be my choice - based on the Gecko. With a PK296A2A-SG7.2 motor wired unipolar (half-coil), I would use the 3.14A setting instead of the 2.57A setting.

The unit requires a common 5VDC, similar to the Gecko G201 and G202 modules. So you would connect the CP+ terminal and the CW+ terminal to +5VDC. You would connect CP- to your step pulse signal (active LOW). You would connect the CW- terminal to your direction signal. The current draw for the step and direction signals would be about 15mA, which is the same as a Gecko G201 or G202.

Pay close attention to the voltage warning of 70VDC maximum; however the PK296A2A motor only requires about 35V to 40V. Also, regardless of the motor's current draw, mount the stepper drivers on a good heat sink to keep them from getting too hot.

There is NO maximum step rate specification on the data sheet. Depending on the gearing, you would expect the unit to handle at least 50,000 pulses per second, more would be better.
Reply With Quote
  #3  
Old Mon 16 March 2009, 00:02
Francois
Just call me: Francois
 
Springs
South Africa
Qj8060

Hi mike thanks for the reply..

I am going to use direct drive for my first build, I will attach the motor I am planning on using, reason for this driver is that I get it for a good price with the motor. I am a bit worried about the fact that it is Chinese make but shipping is much cheaper and I wont know if I donít try. With the motor selection they advices this driver but just want some second opinions before I order.

I get the motor for USD 38.50 and driver for USD 50.00 witch is much cheaper than the famous Gecko.

I will try this unit and give the other MM builders a feed back on this drivers.

Regards,
Attached Files
File Type: pdf 85BYGH450B-06D.pdf (212.3 KB, 175 views)
Reply With Quote
  #4  
Old Mon 16 March 2009, 04:12
Richards
Just call me: Mike
 
South Jordan, UT
United States of America
The data sheet for the 85BYGH450B-06D motor shows that the motor is rated at 2.2mH, 5.A and produces 45kg*cm of torque. If I've done the conversion properly, that motor would work well with a 35VDC to 45VDC power supply (lower voltage=cooler temperature, higher voltage=hotter temperature). The motor develops about 625 oz*in of torque and it requires about 5A of current to properly do its job. In fact, its electrical and torque specifications are very similar to my all time favorite motor, the Oriental Motor PK299-F4.5 when wired unipolar (half-coil).

On the driver, the closest Amp setting is 4.86A which requires SW1=UP, SW2=DOWN, and SW3=UP.

The 1/10th micro-step settings require SW5=UP, SW6=UP, SW7=DOWN and SW8=DOWN.

The motor's Red wire connects to A+, the Green wire connects to A-, the Yellow wire connects to B+ and the Blue wire connects to B-.

Inside the driver is a jumper to select single pulse or double pulse. I don't know what that means. Some drivers have jumpers to allow you to select step/direction or CW/CCW. I'm guessing that that is what the single/double settings are for, where single probably means step/direction and double probably means CW/CCW.

Without a gearbox or a belt-drive reduction unit, you would probably need to use a spur gear with a pitch diameter close to 1-inch (25.4mm) which would give you a step resolution of about 0.0015 inches (0.04mm) per step. A 1.25-inch pitch diameter (31.75mm) spur gear would give you a step resolution of 0.002-inch (0.05mm) per step and a 1.5-inch pitch diameter (38mm) spur gear would give you a step resolution of 0.0023-inch (0.058mm). The larger gears would also reduce the torque. On my Shopbot, the first non-geared motors were furnished with 1-inch pitch diameter gears. It also had motors that produced about 600 oz*in of torque, so I would recommend that you start with 1-inch pitch diameter gears.

If the components are well made and if the data sheet is accurate, the motor and the driver would probably be a good match for the MechMate; however, if I were you, I would consider adding a belt-drive transmission. On my Shopbot, the belt-drive transmission greatly reduced the "chatter" problem that I had with a non-geared motor.
Reply With Quote
  #5  
Old Mon 16 March 2009, 04:58
Francois
Just call me: Francois
 
Springs
South Africa
Thanks

You are making it to easy for me but I am grateful for all the info and it will save me allot of reading, I am going to look at the belt driven transmission. I had it as a secondary option if I was not satisfied with the end product but I think I must take your advice as I can see you have allot more experience than me.

It looks Greek to me but I am sure I will figure it out, I will post questions if I struggle with the gear ratios.

Thanks again.
Reply With Quote
  #6  
Old Thu 30 July 2009, 19:56
les_bosworth
Just call me: Boz
 
Tasmania
Australia
QJ8060 Stepper Drivers

Portion Of E-mail I sent to Bei Lei at CW-Motors, Hope it helps mate

les_bosworth@bigpond.com



Dear Les Bosworth,

Glad to receive your questions .
about the voltage, it can't exceed 80V . our engineer changed it ,but didn't tell me in time .sorry about the mistake.
about the maximum pulse rate is 200KHZ.

about how to setting jumper. your explain it's right . thanks your good suggests .i am very glad to hear it .
you are professional than me about stepper motor driver .

Kind regards
Annie


CW-Motor,cw@cw-motor.com
2009-07-29
----- Original Message -----
From: Les Bosworth
To: cw
Sent: 2009-07-29, 14:23:35
Subject: Driver Questions

Dear Bei Lei
Now that you mention it I do have some questions
The manual for the QJ8060 drivers says not to exceed 70 volts
The drivers I received say on them not to exceed 80 volts, which is correct?
The manual does not mention the maximum pulse rate? This would be handy to know.

The manual does not explain properly the single/double pulse jumper settings

I take it to mean
Single pulse mode - CP input = clock pulse, CW input = direction
Double pulse mode - CP input = anticlockwise, CW input = clockwise
Is this correct.?

Some manufacturers use Double pulse to mean, for each clock pulse the driver takes two steps.
I would suggest you change the terminology you use in your manuals from Pulse Choice to Pulse Modes

And explain the settings with the following two lines.

Clock/Direction CP input = clock pulse, CW input = direction (diagram )
CW/CCW CP input = anticlockwise,CW input = clockwise (diagram )

Just a suggestion, hope you don't mind.
As always, Kindest regards, Les
Reply With Quote
  #7  
Old Tue 14 September 2010, 06:13
Francois
Just call me: Francois
 
Springs
South Africa
Help Please QJ8060

Hi I have attached a pdf of my BOB from the supplier using a gecko drive can any body look at my QJ8060 pfd file and confirm what i have done and also stuff that i missed.
The actual driver data sheet is posted at the top of this threat. QJ8060.

Any help Thanks.
Attached Files
File Type: pdf PowerSupply Model (1).pdf (212.3 KB, 55 views)
File Type: pdf BOB QJ8060.pdf (147.8 KB, 43 views)

Last edited by Francois; Tue 14 September 2010 at 06:21..
Reply With Quote
  #8  
Old Tue 14 September 2010, 08:19
Richards
Just call me: Mike
 
South Jordan, UT
United States of America
Francois,

You have things connected properly. You've connected +5VDC to CP+ and to CW+. You've connected direction to CW-. You've connected step to CP-. GND is NOT connected to either CW- or CP-.

The Enable connection to the stepper driver is a mystery. The data sheet does not say whether that signal enables the stepper driver or whether it disables the stepper driver. (The G201 has a disable input.) If the Enable connection must be active for the stepper driver to work, then connect +5VDC to EN+ and connect GND to EN-. On many stepper drivers, the enable signal allows or shuts off power to the motor. If you leave the enable lines unconnected and then supply power to the stepper driver and if the motors lock up, then you can leave the enable lines unconnected. On the other hand, if you can easily turn the shaft of the stepper motor when power is applied and the enable lines are unconnected, then you must apply +5V to EN+ and Gnd to EN-.

You can connect the GND terminal on the BOB to the GND terminal on the power supply if you want to. That is the recommended procedure; however, the step and direction signals on the stepper driver are opto-isolated so the stepper driver will work if you do not connect the GND line on the BOB to the power supply's ground.

You show that the power supply's (+) voltage connects to the stepper driver through a fuse. Be aware that most fuses will not blow fast enough to protect the stepper driver. The function of a fuse is to keep the wiring from getting hot enough to start a fire. I've stopped using external fuses between the power supply and the stepper drivers on my system. The Geckodrive G203v has a built-in fuse, but the G202, that I often use, does not.

Because you have two inputs per signal on your stepper driver, you could use Active High (sourcing) or Active Low (sinking) signals from the BOB. Active High means that you would connect CP- and CW- to ground, CP+ to step and CW+ to direction. Active Low means that you would connect the stepper driver as you already have. Because the stepper driver requires about 15mA of current to drive the CP and CW signals, Active Low would be the prefered method - unless you are certain that the driver chip on the BOB can source 15mA. Many 'modern' chips can sink or source 24mA per circuit. Traditionally, the 74xx series of chips could sink 15mA current, but they could only source about 10% of that current. That is why so many designs specify Active Low (sinking) signals.

Your schematic does not show any capacitors on your power supply. Be sure to a large filter capacitor. Depending on the load, you'll need between 10,000 uF and 30,000 uF. The formula is: 80,000 X Amps / Voltage

Last edited by Richards; Tue 14 September 2010 at 08:24..
Reply With Quote
  #9  
Old Tue 14 September 2010, 09:16
Francois
Just call me: Francois
 
Springs
South Africa
Thanks

Thanks Mike it makes sense when reading it is a different story when standing in front of that box.... I will have to go back and read again about the cap, see where it fits, Ive seen pictures of the setup... That diagram is as i got it from the supplier i would have done it like that so thanks again for the info...

The motor uses 5 amps the closest setting on the driver is 4.86A and 3.5v ( If i am correct it comes to 111085.71 uF)

The Power supply I Got from the same supplier gave me a 28VAC supply and said that the volts increase when converted through a rectifier to vdc and would be sufficient, i gave him the motor data sheet.....

I don't know the formula to work it out... I am electrical disabled if you know what I mean....

Last edited by Francois; Tue 14 September 2010 at 09:30..
Reply With Quote
  #10  
Old Tue 14 September 2010, 11:59
ecki
Just call me: ecki
 
gabs
Botswana
Using QJ8060 and happy with it. EN+/EN- stay open...
Reply With Quote
  #11  
Old Tue 14 September 2010, 13:11
Kobus_Joubert
Just call me: Kobus #6
 
Dalview
South Africa
Send a message via Yahoo to Kobus_Joubert Send a message via Skype™ to Kobus_Joubert
Hi Francois, glad that you are still building your machine. If you say you got the power supply and BOB from the same supplier (Greg), then you have no problem ...the CAP is already on the power supply board....Mine has 3 caps on I think. I make this assumption as the drawing you supplied is the BOB from Greg at CNC Direct in Edenvale.
Reply With Quote
  #12  
Old Tue 14 September 2010, 13:25
Richards
Just call me: Mike
 
South Jordan, UT
United States of America
Francois,

4.86A would be the correct resistance setting.

Remember that you must multiply the motor's current by the number of motors that you're using. So, 5A per motor X 4 motors = 20A. Because not all of the motors will be pulling full current all of the time, you can use 66% as a valid maximum current. 66% 20A = 13.2A. Your 28VAC transformer will generate SQRT(2) X 28 = about 40V. So, 80,000 X 13A / 40V = 26,000 uF.

You can use the capacitors that you have to start. If the motors run rough under load, add more capacitors. I have a 11,000 uF capacitor on one of my test setups. It works just fine with four motors rated at 4.5A each. (At least for testing purposes.)

You can use the built-in fuses on the power supply, but they probably won't save the stepper drivers. That's not the fault of the power supply or of the fuses, it's just the nature of stepper motors and what they do if power is suddenly removed when the motor is under load.

(The photos you sent in the email are impressive. You're going to have a very fine controller.)

Last edited by Richards; Tue 14 September 2010 at 13:39..
Reply With Quote
  #13  
Old Tue 14 September 2010, 13:29
Francois
Just call me: Francois
 
Springs
South Africa
Hi Uncle Kobus hehehe

Thanks Kobus yes I am 90% done took me about 4 months just to get from 80 to 90%. Cables was stolen, computer an allot of other stuf... Almost gave up!
Machine is sprayed (not blue) had to use what was avalible... All and all almost there but not close to the standard of mechmates coming out of this forum...

Yes it was bought from Greg, he is a real nice bloke.... So i do not have to worry about Cap's. Ecki you bought after me and your done before me. Nice!!!

I thought the drivers looked of a good quality and for the price it was almost irresistible, we will just have to see how long they keep going..

Thank for the help guys.
Reply With Quote
  #14  
Old Tue 14 September 2010, 13:31
Francois
Just call me: Francois
 
Springs
South Africa
Thanks Mike
Reply With Quote
Reply

Register Options Profile Last 1 | 3 | 7 Days Search Today's Posts Mark Forums Read

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 03:57.


Powered by vBulletin® Version 3.8.3
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.