MechMate CNC Router Forum

Go Back   MechMate CNC Router Forum > Personal Build Histories > Construction started, but not cutting yet
Register Options Profile Last 1 | 3 | 7 Days Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #61  
Old Sat 10 December 2016, 03:52
NikolayUa24
Just call me: NikolayUa24
 
Smila, Cherkasskaja
Ukraine
linear rails HIWIN HGH15 ?
Reply With Quote
  #62  
Old Tue 20 December 2016, 03:22
vallie4
Just call me: towanda
 
Londo
United Kingdom
Excellent job so far! Keep them coming!
Reply With Quote
  #63  
Old Thu 27 April 2017, 22:34
IamDave
Just call me: Davey
 
Ball Ground, GA
United States of America
I also have used a ShopBot. You are way more secure than the old models the Mechmate was based on.
Reply With Quote
Reply

Register Options Profile Last 1 | 3 | 7 Days Search Today's Posts Mark Forums Read

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fast progress on Control Box and Base Table - Vic AU rival MechMates already cutting 16 Wed 07 September 2011 20:30
The www.mechmate.com baton has been passed on Gerald D About this Forum 101 Tue 13 July 2010 22:43
Milwaukee 5625, how fast do you turn it. dragonfinder1 50. Toolheads 5 Tue 16 March 2010 11:33
Hello to all . . . . - Baton Rouge, LA MechMateCajun Introduce yourself and start planning 3 Sun 31 May 2009 05:58
Interested in indexer - Baton Rouge, La. USA Glenn D Construction started, but not cutting yet 15 Sat 30 August 2008 17:35


All times are GMT -6. The time now is 05:27.


Powered by vBulletin® Version 3.8.3
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.