MechMate CNC Router Forum

Go Back   MechMate CNC Router Forum > Electrical & Electronic > 701. Motor Drives
Register Options Profile Last 1 | 3 | 7 Days Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old Tue 25 April 2006, 00:30
Gerald_D
Just call me:
 
Geckodrives (California USA)

This is the classic "Gecko":




They live at www.geckodrive.com. My immediate interest is in the G200 range of Gecko's for driving stepping motors. The Mechmate used G201's. However, adding the capacitors within 1" of the drive was not pretty, and in future I will use G202's. Note added Jul 2008: Now also using G203V drives. (The V is for Vampire. It is not for Vacuum - do not buy G203V with the Vacuum option)

The first impression on meeting a Gecko in real life was that it is very small! Only 2.5" (64mm) square and less than 1" (25mm) high. But you do need one Gecko for each motor and a row of Gecko's starts to look substantial....
Reply With Quote
  #2  
Old Tue 25 April 2006, 00:47
Gerald_D
Just call me:
 
Here are 4 Gecko's lined up on a test board to drive the 4 motors on a PRT Shopbot:




The 75V power supply and fuses occupy the top part of the board. The power supply section has now been tidied up as per this thread. You can see the capacitor placed on each Gecko 201 - the G202 has the capacitor inside and is therefore a little wider, but the installation will be neater. The G203V is the same size as the G201 - but it is NOT directly replaceable (the supply to the "Common" pin must be changed)

The grey cables are the beginnings of the cables out to each stepper motor plug. (Notice how the screens of those cables are connected to a ground/earth point at one end)

What you see in the photo above is the "Heavy" current sides of the Geckos connected. Each Gecko gets 75V DC on the red & black wires coming from the fuses. And then each Gecko drives out 4 wires to the coils of each stepper motor. So, the left hand, (or upper in the second photo), is all connected. The right hand (lower) six terminals of the Gecko must yet be connected to something that feeds in intelligent information....(will be covered in another thread)
Reply With Quote
  #3  
Old Sun 21 May 2006, 03:31
Gerald_D
Just call me:
 
To get an idea of physical sizes involved......
Reply With Quote
  #4  
Old Thu 15 February 2007, 23:57
reza forushani
Just call me:
 
Gerald
How do you slide the cover off the Gecko?
Reply With Quote
  #5  
Old Fri 16 February 2007, 00:04
Gerald_D
Just call me:
 
The cover has two small screws from the bottom that need to be removed first. But, above> (was in another thread) I was talking of the connector blocks, which you just pull vertically up (90 degree to wire direction)
Reply With Quote
  #6  
Old Fri 16 February 2007, 00:18
reza forushani
Just call me:
 
I tried pushing the connectors up with a lot of force without any success. I don't want to break it. Maybe the 202v is different from 202. Do you have a picture of this?
Reply With Quote
  #7  
Old Fri 16 February 2007, 01:25
Gerald_D
Just call me:
 




When sliding the cover off, you have to lift it over the LED (light) a little bit.

The photos are of a G201. The other drives are slightly different.

Do not remove the connectors too often - they can wear out. (A batch of connectors was recalled a year ago because of this issue. The supplier has since been changed)

Don't remove the connectors unless the geckos are completely dead (un-powered) with the capacitors fully discharged (g201/202 LED dead for 5 seconds - the 203 has other LEDs). This allows you to insert a screwdriver underneath for leverage without fear of shorting something.

The connectors are split/joined in two halves of 6 pins each. Although it appears that only 3 pins make one connector, they are in fact joined to an adjacent connector.

Gecko supplier part no.'s:
On-Shore Technology the 130-series
BlockMaster. part no. DGPBP111-12-ON

Some RS component stock codes for the connector blocks.

Wieland
2 way 181-4254
3 way 181-4260
4 way 181-4276
6 way 181-4282

Phoenix Contact
2 way 468-0919
3 way 468-0925
4 way 468-0931
Reply With Quote
  #8  
Old Thu 22 February 2007, 16:10
reza forushani
Just call me:
 
Gerald as you know I got the G203V. In the manual it says "Term 11 and 12 are for current resistor". Do I need a resistor?


I am calculating a 12k ohm resistor. Is this correct anybody?
Reply With Quote
  #9  
Old Thu 22 February 2007, 21:24
Mike Richards
Just call me:
 
Reza,

The Gecko G203 manual says:

The G203V will accommodate motor winding currents from 0 to 7A. Use the following equation to calculate the value, (in kilo-Ohms) of the current set resistor: R (in kilo-ohms) = 47 * I / (7 - I) corrected later

So a 12k resistor would be used with a motor rated at about 1.5-amps

Here are some other values:
1 amp = 8k
2 amp = 19k
3 amp = 35k
4 amp = 63k
5 amp = 118k
6 amp = 282k

(Remember that you can use the closest standard 1/4-Watt resistor value, i.e. 3-amp motor would use a 33k 1/4-watt resistor.)
Reply With Quote
  #10  
Old Thu 22 February 2007, 22:15
Gerald_D
Just call me:
 
Reza, you definitely need a resistor if you don't want to cook the motor.

Before Mike or I can give you a definite size on the resistor, you need to tell us which motor you are using. (I presume you will wire the motor in unipolar mode)
Reply With Quote
  #11  
Old Thu 22 February 2007, 23:26
reza forushani
Just call me:
 
I am using the Oriental Motor recommended. I guess I will start with Unipolar and see what happens. Isn't that the way you are using yours? So, my motor should be running at 1.5 A.
For that I need 12K. Please correct me if I am wrong?
Reply With Quote
  #12  
Old Thu 22 February 2007, 23:58
Gerald_D
Just call me:
 
Reza, your resistor calc is solid for the PK296A1A-SG7.2 motor in unipolar configuration. A 12k resistor should be commonly available.

Suggest you also buy a set of 8k resistors in case you want to try the bipolar mode at some time. 8.2k might be more commonly available and they are also okay.

Unfortunately, you need to check the salesguys when they hand you these tiny things. Best way is with an ohmmeter/multimeter.
Reply With Quote
  #13  
Old Fri 23 February 2007, 00:02
Gerald_D
Just call me:
 
While we are talking of setting the geckodrive with a resistor, we might as well remember that the gecko must be "tuned" to your particular motors for resonance. There is a tiny potentiometer to be gently adjusted by a tiny screwdriver. See the instruction sheet. (might not apply to "vampire" model?).
Reply With Quote
  #14  
Old Fri 23 February 2007, 00:16
reza forushani
Just call me:
 
I am actually using pk292a1a-3.6, I suppose that doesn't change anything. The Vampire controller has a little screw for adjustment also.
Reply With Quote
  #15  
Old Fri 23 February 2007, 00:31
Gerald_D
Just call me:
 
Same logic and value for the PK296A1A-SG3.6 (not pk292...)
Reply With Quote
  #16  
Old Fri 23 February 2007, 14:41
Hugo Carradini
Just call me:
 
Hello reza. You are making good questions and Gerald is giving very explicit answers. I am going to use the same motors and the same Geckos so know that you are ahead I think the road will be clear out. reza would be nice to see how you install the resistor. Gerald the description of the red, yellow and green buttons is very nice to use.
Reply With Quote
  #17  
Old Fri 23 February 2007, 16:12
reza forushani
Just call me:
 
Gerald is our God. I have never done anything like this. Remeber I used to be a software programmer for 10 years and been building homes for 15 years. Not too much electrical/electronics or Steel construction background. But, Gerald and other friends are very helpful, patient and nice 9to dumb questions). I think I can figure it out with their help.


I see the capacitor in the pictures on top but not the resistor?
Reply With Quote
  #18  
Old Fri 23 February 2007, 20:57
Gerald_D
Just call me:
 
Look very carefully!

Here is a bigger pic:



If you are following this Forum, you should not be fitting capacitors. They were only needed for the G201 gecko - the G202 and G203 do not need them.
Reply With Quote
  #19  
Old Fri 23 February 2007, 21:12
reza forushani
Just call me:
 
Thanks. Yes I know for G201 capacitors were needed, but later versions like 202 and 203v don't need. That resistor is pretty small!
I have most of the Control Panel set up except for power supply. It's in the mail somewhere.
As soon as I get the PS and wires I will finish it up. I am still trying to upload pictures.
Reply With Quote
  #20  
Old Sun 25 February 2007, 21:27
reza forushani
Just call me:
 
Hi Gerald

I ordered another relay.

Now I installed Mach3 and connected one stepper motor and Gecko. Now, I ran a g-code (I don't know anything about g-code or mach yet) program called cut-a-circle and it started to turn the motor in both directions. The motor is heating up very quickly and also makes a lot of noise. I know you said it needs to be tuned, I also know the dial on the Gecko is used to tune it. How do I go about doing this. Do I need to run a program in Mach and while it's running tune it or how? Thanks
Reply With Quote
  #21  
Old Sun 25 February 2007, 21:40
reza forushani
Just call me:
 
BTW, I used the black wire of the motor for phase a, yellow for phase a-, red for phase b, yelloow for phase b-. Are these the right wires to be used for Unipolar? The resistor is 1/4 w and 12k.
Reply With Quote
  #22  
Old Sun 25 February 2007, 22:07
Gerald_D
Just call me:
 
Did you check the resistor with an ohmmeter?
Reply With Quote
  #23  
Old Sun 25 February 2007, 22:08
reza forushani
Just call me:
 
yes and ut's ok. is my wiring right
Reply With Quote
  #24  
Old Sun 25 February 2007, 22:09
Gerald_D
Just call me:
 
Did you separately insulate the motor wires that are not used?

I will go and check the wire colours now......
Reply With Quote
  #25  
Old Sun 25 February 2007, 22:16
Gerald_D
Just call me:
 
In your description, you used the yellow twice??? The last time you mention yellow, it should be white instead.

A: Black/yellow
B: Red/White

(green & blue not touching anything, not connected to each other.)

You already got movement!!!! That is a good surprise!

First we will have some coffee, and then talk about the tuning. It is not critical for you now.
Reply With Quote
  #26  
Old Sun 25 February 2007, 22:21
reza forushani
Just call me:
 
I have black.yellow, red.white.
Green and Blue are free and not touching.

Yes we have movement.

Coffee is on me. Let me pour you a cup?!
Reply With Quote
  #27  
Old Sun 25 February 2007, 22:45
Gerald_D
Just call me:
 
Are you absolutely sure the resistor is 12k and not 120k? That motor should only be slightly warmer than room temperature after about 30 minutes to an hour. If you left it on all day then you should still be able to hold your hand on it very comfortably for a loooong time.

You are making it sound like you can brew coffee on your motor? Well, a stepper is allowed to get that hot, but in this case there is something very wrong. It can only be the resistor choice, a faulty gecko (unlikely), a faulty motor (very unlikely), or a bad connection between the resistor and the gecko (possible?).

I suggest you cure the heat problem while the PMDX is not connected - take it one step at a time......

Thanks for the first coffee, pour me another please? (while your motor is still hot)
Reply With Quote
  #28  
Old Sun 25 February 2007, 22:58
reza forushani
Just call me:
 
Hi Gerald: COFFEE WAS THE CULPRIT OR the lack of enough of it.

Yes you were right. There was a loose connection. Everything works now perfectly. Things are quiet and cold.

You win another round. This is a temporary set up as I havn't got my permanent cables yet. Hopefully next of days, I will the cables and complete the control panel. Tommorrow I am suppose to get the laser parts and other steel and get started on the table.

Thanks again for everything and being such a wonderfull mentor.
Reply With Quote
  #29  
Old Sun 25 February 2007, 23:15
Gerald_D
Just call me:
 
This is a perfect illustration of why this must be done on the kitchen table! Imagine building the full-size beast and then walking around it to learn these lessons....
Reply With Quote
  #30  
Old Mon 26 February 2007, 17:46
Hugo Carradini
Just call me:
 
Reza, you really nohow to keep us in tension. It is a good way to keep our attention on this nice tread.
We will need some extra coffee.
Reply With Quote
Reply

Register Options Profile Last 1 | 3 | 7 Days Search Today's Posts Mark Forums Read

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 22:08.


Powered by vBulletin® Version 3.8.3
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.